Summary: Build tool for D
Name: rebuild
Version: 0.15
Release: 0%{?dist}
Group: Development/Tools
License: Artistic or GPL
URL: http://dsource.org/projects/dsss/

Source: http://svn.dsource.org/projects/dsss/downloads/%{name}/%{version}/%{name}-%{version}.tar.bz2
Source1: http://gdcgnu.sourceforge.net/rebuild.1
BuildRoot: %{_tmppath}/%{name}-%{version}-root

%description
Rebuild is a tool for building D software.
It is based on the frontend to the DMD D compiler.

Essentially, for any D source file given, rebuild finds all
dependencies, and compiles them all into the target. 

%prep
%setup
cp %{SOURCE1} .

%build
make CXXFLAGS="$RPM_OPT_FLAGS"

%install
rm -rf $RPM_BUILD_ROOT
make install PREFIX="$RPM_BUILD_ROOT%{_prefix}"
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install -p rebuild.1  $RPM_BUILD_ROOT%{_mandir}/man1
mv $RPM_BUILD_ROOT%{_prefix}/etc $RPM_BUILD_ROOT%{_sysconfdir} || :
rm -rf $RPM_BUILD_ROOT%{_prefix}/share/doc

%clean
rm -rf $RPM_BUILD_ROOT

%files
%doc README
%doc artistic.txt gpl.txt
%defattr(-,root,root)
%{_bindir}/rebuild
%{_mandir}/man1/rebuild.1*
%{_libdir}/*.d
%dir %{_sysconfdir}/rebuild
%config %{_sysconfdir}/rebuild/*